Windows 10: bei Nutzung einer SSD sollte Superfetch deaktiviert werden - so funktioniert es

Diskutiere Windows 10: bei Nutzung einer SSD sollte Superfetch deaktiviert werden - so funktioniert es im Windows 10 FAQ Forum im Bereich Windows 10 Foren; Microsoft wie schon bei seinen vorherigen Windows-Versionen auch unter Windows 10 den Dienst SuperFetch integriert, welcher dafür sorgt, alle...
maniacu22

maniacu22

Erfahrener Benutzer
Threadstarter
Mitglied seit
05.05.2014
Beiträge
2.314
Ort
Leipzig
Version
Windows 10 Pro 64 Bit - Build 1709
System
Intel Core i5-3570K, 32 GB RAM, 500 GB Crucial MX200, HIS Radeon HD 5750 Passiv
Microsoft wie schon bei seinen vorherigen Windows-Versionen auch unter Windows 10 den Dienst SuperFetch integriert, welcher dafür sorgt, alle benötigten und häufig genutzten Anwendungen bereits im Vorfeld in den Arbeitsspeicher geladen werden und somit deutlich schneller gestartet werden können. Da dieser Dienst allerdings aus Zeiten herkömmlicher Festplatten stammt und heutige SSD-Laufwerke an sich schon schnell genug sind, ist dieser Dienst unnötig geworden. Viel mehr noch. SuperFetch sorgt auf SSD-Laufwerken für unnötig viele Lese- und Schreibvorgänge, wodurch sich die Lebensdauer der Speicherzellen verkürzen kann. Welche Möglichkeiten es gibt, die Funktion SuperFetch deaktivieren oder auch wieder aktivieren zu können, soll euch dieser Praxis-Tipp erläutern




Vor der Ära der SSD-Laufwerke war es für Windows-Nutzer wichtig, öfter benötigte Programme und Anwendungen im Arbeitsspeicher bereit zu halten, so dass diese bei einem Start schneller geladen werden können. Da mittlerweile viele Nutzer von den Vorteilen der schnellen SSD-Laufwerke überzeugt sind, bedarf es dieser Windows-Funktion namens SuperFetch nicht mehr. Vielmehr sorgt SuperFetch sogar dafür, dass auf den SSD-Laufwerken unnötige Lese- und Schreibvorgänge stattfinden, was deren Lebensdauer über einen längeren Zeitraum drastisch verringern kann. Windows 10 bietet wie auch schon Windows 7 und Windows 8 mehrere Möglichkeiten, die SuperFetch-Funktion zu deaktivieren. Zwei dieser Methoden möchte ich euch nachfolgend vorstellen.


SuperFetch über Windows-Services deaktivieren:


  • betätigt die Tastenkombination Windows +R um das Ausführen-Fenster zu öffnen
  • gebt hier den Befehl services.msc ein und betätigt Enter
  • in der sich nun geöffneten Dienste-Liste sucht ihr den Eintrag SuperFetch, welchen ihr mittels Doppelklick öffnet
  • in dem sich nun geöffneten Eigenschaften-Fenster wählt ihr über das Dropdown-Menü bei Starttyp den Eintrag Deaktiviert aus
  • nachdem ihr die Einstellungen übernommen habt, könnt ihr alle geöffneten Fenster schließen
  • abschließend muss Windows neu gestartet werden, damit die Einstellungen aktiv werden




SuperFetch über die Registry deaktivieren / konfigurieren:

Wie so oft, lässt sich das Windows-Verhalten über die Registry etwas detaillierter einstellen, was auch im Fall von SuperFetch der Fall ist. Allerdings empfehle ich diese Vorgehensweise nur versierten Nutzern, da bei fehlerhaften Einstellungen keine Garantie übernommen werden kann.


  • betätigt wieder die Tastenkombination Windows + R um das Ausführen-Fenster zu öffnen
  • gebt nun den Befehl regedit ein, um die Registry zu öffnen
  • navigiert nun zu folgendem Schlüssel
    Code:
    ComputerHKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerMemory ManagementPrefetchParameters
    den ihr auch einfach kopieren und in die Suchleiste der Registry einfügen könnt
  • im rechten Feld führt ihr nun einen Doppelklick auf den Eintrag EnablePrefetcher aus
  • unter Wert habt ihr nun die Möglichkeit, unter folgenden SuperFetch-Modi wählen zu können

  • 0: SuperFetch ist deaktiviert
  • 1: beschleunigt den Start von Programmen
  • 2: beschleunigt den Bootvorgang
  • 3: beschleunigt Start von Programmen sowie auch den Bootvorgang




Standardmäßig ist hier der Wert "3" eingetragen, wodurch der Programmstart als auch der Bootvorgang beschleunigt wird. Sollte euer Windows auf einer SSD installiert sein, sollte auf den Wert 0 umgestellt werden.
 
#
Schau dir mal diesen Ratgeber an. Dort wird jeder fündig!
Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thomas62

Thomas62

Erfahrener Benutzer
Mitglied seit
30.07.2015
Beiträge
2.497
Ort
Wunderschönen Berlin
Version
DESKTOP Win 10 Pro 64 bit Build aktuell
System
ASUS Prime A320M-K AMD A10-9700, 4x 3.50GHz +16 GB Ram ZOTAC 970 GTX 4 GB Ram Win 10 (64 bit) Pro
Hmm,

habe aber
EnablePrefetcher mit wert (3)
EnableSuperfetch mit wert (3)

weil mal wird von SuperFetch gesprochen und gezeigt wird aber EnablePrefetch

im rechten Feld führt ihr nun einen Doppelklick auf den Eintrag EnablePrefetcher aus
unter Wert habt ihr nun die Möglichkeit, unter folgenden SuperFetch-Modi wählen zu können
das irritiert mich leicht !

muss ich dann beide auf ( 0 ) setzen ?
Unbenannt.JPG
lg
 
Zuletzt bearbeitet:
maniacu22

maniacu22

Erfahrener Benutzer
Threadstarter
Mitglied seit
05.05.2014
Beiträge
2.314
Ort
Leipzig
Version
Windows 10 Pro 64 Bit - Build 1709
System
Intel Core i5-3570K, 32 GB RAM, 500 GB Crucial MX200, HIS Radeon HD 5750 Passiv
Wie du siehst, habe ich auf den Screenshots nur "EnablePrefetcher" stehen, dessen wert ich von 3 auf 0 gesetzt habe.
Wo hast du denn noch "EnableSuperFetch" gefunden? Jetzt verwirrst du mich aber :rolleyes:
 
Thomas62

Thomas62

Erfahrener Benutzer
Mitglied seit
30.07.2015
Beiträge
2.497
Ort
Wunderschönen Berlin
Version
DESKTOP Win 10 Pro 64 bit Build aktuell
System
ASUS Prime A320M-K AMD A10-9700, 4x 3.50GHz +16 GB Ram ZOTAC 970 GTX 4 GB Ram Win 10 (64 bit) Pro
Bin ja selber verwirrt das es überhaupt dort steht !

Keine Ahnung wo das herkommt , oder evtl. vom Sandisk Dashboard weil die SSD ja von Sandisk ist .

Wäre so meine Erklärung. Aber sonst bin ich mir nicht bewusst das ich es irgendwann mal manuell eingefügt hätte .

Aber auch egal Rechner läuft perfekt ! Alles da wo es sein soll . Er macht auch was er soll !

lg
 
Westend

Westend

Erfahrener Benutzer
Mitglied seit
30.01.2018
Beiträge
1.697
Ort
HH
Version
Windows 10 pro 18363.aktuell und Win10 pro Insider 20H1
System
Lenovo H50-50 8GB Ram GTX 745, iMac 27" 4,2 GHz i7 16GB Ram Radeon pro mit 8GB
Moin,
in der Registry habe ich das auch stehen, ohne SSD.
 
areiland

areiland

Super-Moderator
Mitglied seit
25.08.2014
Beiträge
25.634
Ort
Ludwigshafen
Version
Windows 10 Pro x64 immer aktuell!
System
970M Pro3, FX8350, RX560, 16GB DDR3 1600, 860Evo256 GB, MK7559GSXP, SH224BB, BenQ GW2780
Habt ihr eure Systeme vielleicht nach dem Upgrade nie neu aufgesetzt? Der Wert "EnableSuperFetch" ist nämlich eigentlich ein Überbleibsel von früher, der von Windows 10 eigentlich auch nicht mehr ausgewertet werden dürfte.
 
Zuletzt bearbeitet:
Westend

Westend

Erfahrener Benutzer
Mitglied seit
30.01.2018
Beiträge
1.697
Ort
HH
Version
Windows 10 pro 18363.aktuell und Win10 pro Insider 20H1
System
Lenovo H50-50 8GB Ram GTX 745, iMac 27" 4,2 GHz i7 16GB Ram Radeon pro mit 8GB
Win 10 habe ich schon min. 10mal neu aufgesetzt.
Zuletzt die 1709 clean installiert.
Gruß
 
Thomas62

Thomas62

Erfahrener Benutzer
Mitglied seit
30.07.2015
Beiträge
2.497
Ort
Wunderschönen Berlin
Version
DESKTOP Win 10 Pro 64 bit Build aktuell
System
ASUS Prime A320M-K AMD A10-9700, 4x 3.50GHz +16 GB Ram ZOTAC 970 GTX 4 GB Ram Win 10 (64 bit) Pro
Ich hatte mein System mit dem Installationstool von MS als CleanInstall aufgesetzt .

Und bis heute nur Updates die kamen Installiert .

Also wenn ich richtig verstehen sollte kann der schlüssel mit EnableSuperfetch gelöscht werden ?
 
dau0815

dau0815

Erfahrener Benutzer
Mitglied seit
11.08.2015
Beiträge
2.599
Am besten löscht man gar nichts aus der Registry. Nicht benötigte Einträge machen keinerlei Probleme. Kosten auch keine Performance.
Man weiß aber nie, was man sich evtl. für Probleme einhandelt, wenn man irgend etwas löscht.
 
areiland

areiland

Super-Moderator
Mitglied seit
25.08.2014
Beiträge
25.634
Ort
Ludwigshafen
Version
Windows 10 Pro x64 immer aktuell!
System
970M Pro3, FX8350, RX560, 16GB DDR3 1600, 860Evo256 GB, MK7559GSXP, SH224BB, BenQ GW2780
So siehts aus, einfach ignorieren!
 
Thomas62

Thomas62

Erfahrener Benutzer
Mitglied seit
30.07.2015
Beiträge
2.497
Ort
Wunderschönen Berlin
Version
DESKTOP Win 10 Pro 64 bit Build aktuell
System
ASUS Prime A320M-K AMD A10-9700, 4x 3.50GHz +16 GB Ram ZOTAC 970 GTX 4 GB Ram Win 10 (64 bit) Pro
auch nicht wenn sie sich VERMUTLICH gegenseitig beeinflussen bzw. aufheben .

Nicht gesehen was gemeint ist ?

lg
 
areiland

areiland

Super-Moderator
Mitglied seit
25.08.2014
Beiträge
25.634
Ort
Ludwigshafen
Version
Windows 10 Pro x64 immer aktuell!
System
970M Pro3, FX8350, RX560, 16GB DDR3 1600, 860Evo256 GB, MK7559GSXP, SH224BB, BenQ GW2780
Wenn Windows den Registrywert nicht auswertet, dann kann er den anderen auch nicht beeinflussen oder aufheben. Das ist dann einfach nur noch eine nicht beachtete Zeichenkette.
 
Westend

Westend

Erfahrener Benutzer
Mitglied seit
30.01.2018
Beiträge
1.697
Ort
HH
Version
Windows 10 pro 18363.aktuell und Win10 pro Insider 20H1
System
Lenovo H50-50 8GB Ram GTX 745, iMac 27" 4,2 GHz i7 16GB Ram Radeon pro mit 8GB
@Alex
In meiner Insider 17604 installiert in einer VM ist der Eintrag auch noch vorhanden.
 
areiland

areiland

Super-Moderator
Mitglied seit
25.08.2014
Beiträge
25.634
Ort
Ludwigshafen
Version
Windows 10 Pro x64 immer aktuell!
System
970M Pro3, FX8350, RX560, 16GB DDR3 1600, 860Evo256 GB, MK7559GSXP, SH224BB, BenQ GW2780
Bei mir gibts den gar nicht mehr, möglicherweise wird der durch einen Treiber oder eine andere Komponente gesetzt, die bei den anderen nicht vorhanden sind.
 
Thomas62

Thomas62

Erfahrener Benutzer
Mitglied seit
30.07.2015
Beiträge
2.497
Ort
Wunderschönen Berlin
Version
DESKTOP Win 10 Pro 64 bit Build aktuell
System
ASUS Prime A320M-K AMD A10-9700, 4x 3.50GHz +16 GB Ram ZOTAC 970 GTX 4 GB Ram Win 10 (64 bit) Pro
hmm,

habe mal versucht mit wert (0) und (3) .

Kein fühlbarer Unterschied ! Boottime immer so um 40-45 sek. ( MBR )

Aber Rechner läuft perfekt zu 99 %
 
maniacu22

maniacu22

Erfahrener Benutzer
Threadstarter
Mitglied seit
05.05.2014
Beiträge
2.314
Ort
Leipzig
Version
Windows 10 Pro 64 Bit - Build 1709
System
Intel Core i5-3570K, 32 GB RAM, 500 GB Crucial MX200, HIS Radeon HD 5750 Passiv
weiss-nicht

weiss-nicht

Erfahrener Benutzer
Mitglied seit
13.09.2014
Beiträge
479
navigiert nun zu folgendem Schlüssel Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlS et\Control\Session Manager\Memory Management\PrefetchParameters den ihr auch einfach kopieren und in die Suchleiste der Registry einfügen könnt
Kannst du den Leerschlag bei ControlSet herausnehmen, sonst funzt das kopieren nämlich nicht
Danke
 
maniacu22

maniacu22

Erfahrener Benutzer
Threadstarter
Mitglied seit
05.05.2014
Beiträge
2.314
Ort
Leipzig
Version
Windows 10 Pro 64 Bit - Build 1709
System
Intel Core i5-3570K, 32 GB RAM, 500 GB Crucial MX200, HIS Radeon HD 5750 Passiv
@weiss-nicht:

sorry, vergessen dass die Forensoftware keine Codes mit mehr als 20 Zeichen oder so korrekt annimmt. Habs jetzt in ein Code-Fenster geschoben, so sollte es gehen ;)
 
Thomas62

Thomas62

Erfahrener Benutzer
Mitglied seit
30.07.2015
Beiträge
2.497
Ort
Wunderschönen Berlin
Version
DESKTOP Win 10 Pro 64 bit Build aktuell
System
ASUS Prime A320M-K AMD A10-9700, 4x 3.50GHz +16 GB Ram ZOTAC 970 GTX 4 GB Ram Win 10 (64 bit) Pro
Kannst du den Leerschlag bei ControlSet herausnehmen, sonst funzt das kopieren nämlich nicht
Danke

brauch man doch nur Leerzeichen wegnehmen . :rolleyes:
 
G

Gast

Hallo Leute,

lasst doch einfach mal alle Einstellungen so wie sie sind, wenn das System rund läuft.
SSD's wurden in vielen Fachzeitschriften einem Dauertest unterzogen und dabei wurde festgestellt, dass SSD's deutlich länger halten, als die angegebenen MTBF Angaben des Herstellers. Ob nun das Prefetching läuft oder nicht ist völlig wurscht ;)
 
Thema:

Windows 10: bei Nutzung einer SSD sollte Superfetch deaktiviert werden - so funktioniert es

Windows 10: bei Nutzung einer SSD sollte Superfetch deaktiviert werden - so funktioniert es - Ähnliche Themen

  • Neuestes Windows 10 Update (Version 1903, August 2019) erschwert die Nutzung von Office 2016

    Neuestes Windows 10 Update (Version 1903, August 2019) erschwert die Nutzung von Office 2016: Der Titel sagt es schon, das neueste Windows 10 Update (Version 1903, August 2019) erschwert die Nutzung von Office 2016 und nur das davor...
  • Neuestes Windows 10 Update erschwert die Nutzung von Office 2016

    Neuestes Windows 10 Update erschwert die Nutzung von Office 2016: Der Titel sagt es schon, das neueste Windows 10 Update (August 2019) erschwert die Nutzung von Office 2016 und nur das davor installierte Office...
  • Verzögerte Nutzung einer Bluetooth Maus nach dem Hochfahren- Windows 10

    Verzögerte Nutzung einer Bluetooth Maus nach dem Hochfahren- Windows 10: Hallo liebe Community, ich habe Windows 10 und seit Kurzem eine Bluetooth-Maus. Allerdings erkennt Windows die Maus nachdem Hochfahren erst ca...
  • Windows Update und OneDrive verbinden nicht bei Nutzung im Ausland

    Windows Update und OneDrive verbinden nicht bei Nutzung im Ausland: Hallo liebe Community! Ich bin seit einigen Tagen in Mexiko und werde dort die nächsten Monate verbringen. Leider baut mein PC keine Verbindung...
  • Nutzung von privaten DVD in Windows 10

    Nutzung von privaten DVD in Windows 10: Ich habe in meiner privaten Sammlung diverse DVD`s, die Teils von Künstlerbiographien handeln, doer Anleitungen zum Malen&Zeichnen, sowie...
  • Ähnliche Themen

    Oben