ODYS Windesk 9 plus 3G V1.7.6 Flash HDD nicht mehr erkannt

Diskutiere ODYS Windesk 9 plus 3G V1.7.6 Flash HDD nicht mehr erkannt im Windows 10 Tablet-PCs Forum im Bereich Windows 10 Foren; Hallo Zusammen, ich besitze ein ODYS Windesk 9 plus 3G V1.7.6 (Produktdetails: ODYS Windesk 9 plus 3G 2in1), bei dem Windows nicht mehr gebootet...
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Hallo Zusammen,

ich besitze ein ODYS Windesk 9 plus 3G V1.7.6 (Produktdetails: ODYS Windesk 9 plus 3G 2in1), bei dem Windows nicht mehr gebootet wird, ich lande immer nur in der EFI Shell version 2.31 [5.8]:
Code:
EFI Shell version 2.31 [5.8]
Current running mode 1.1.2
Device mapping table
blk0: BlockDevice - Alias (null)
      PciRoot(0x0)/Pci(0x17,0x0/Ctrl(0x0)
blk1: BlockDevice - Alias (null)
      PciRoot(0x0)/Pci(0x17,0x0)/Ctrl(0x1)
blk2: BlockDevice - Alias (null)
      PciRoot(0x0)/Pci(0x17,0x0)/Ctrl(0x2)

Press ESC in 5 seconds to skip startup.nsh, any other key to continue.
Shell>

Das Problem trat auf, nachdem ich einen blauen Bildschirm unter Windows erhielt. Ich weiß nicht mehr genau, was dort stand, vermutlich war es aber dieser, und wurde durch ein Windows Update verursacht:
error 0xc0000017

Die dort beschriebene Vorgehensweise kann aber nicht weiter verfolgt werden, da mir keine Windows-Partition vorliegt, ich kann somit auch kein bcdedit ausführen. Ich vermute daher, dass die Flash HDD einen Wackelkontakt oder Defekt hat.

Zunächst dachte ich, dass im BIOS der Windows Boot Manager verstellt ist, aber dieser steht nicht mehr zur Verfügung, nur:
UEFI: Built-in EFI Shell

Im Produktblatt ist zu sehen, dass als interner Speichern eine 32 GB Flash HDD verbaut ist. Ich habe per USB Stick die Recovery Console gestartet,
und geprüft, ob ein Betriebssystem gefunden werden kann, jedoch ohne Erfolg:
Code:
>bootrec /rebuildbcd

Alle Datenträger werden nach Windows-Installationen durchsucht.

Bitte warten, dies kann einige Zeit in Anspruch nehmen...

Die Suche nach Windows-Installationen war erfolgreich.
Gesamtanzahl der identifizierten Windows-Installationen: 0
Der Vorgang wurde abgeschlossen.

Wenn ich die Installation starten will, wird doch nur eine 7GB große HDD mit nicht zugewiesenem Speicher angezeigt (scheint nicht die Windows-Disk zu sein),
darauf kann ich Windows auch nicht neu installieren (Speicherplatz wäre auch knapp bzw. zu gering).

Habe alles mögliche mit diskpart probiert, aber scheitert natürlich auch, da es nicht die korrekt Disk ist:
Code:
>diskpart

DISKPART>list disk

Datenträger ### Status Größe    Frei     Dyn GPT
----------- --- ------ -------  -------  --- ---
Datenträger  0  Online 7393 MB  7393 MB

DISKPART>select disk 0

Datenträger 0 ist jetzt der gewählte Datenträger.

DISKPART>clean

Der Datenträger wurde bereinigt.

DISKPART>convert gpt
Fehler beim Dienst für virtuelle Datenträger:
Objekt wurde nicht gefunden.


DISKPART>list disk
  Datenträger ### Status Größe    Frei     Dyn GPT
  ----------- --- ------ -------  -------  --- ---
* Datenträger  0  Online 7393 MB  7393 MB


DISKPART>create partition primary

Fehler beim Dienst für virtuelle Datenträger:
Objekt wurde nicht gefunden.

Ich bin nun ziemlich ratlos. Hatte evtl. vermutet, dass ich im BIOS/UEFI auf Legacy umstellen muss, aber meine BIOS-Version hat diese Einstellung nicht.
Und zum Thema BIOS flashen kann ich nicht wirklich etwas ändern, da mir der Mainboard-Hersteller nicht bekannt ist.

Ein paar Informationen aus dem BIOS:
Code:
Im Menüpunkt zum Flashen ist alles ausgegraut:

Security:
Signed BIOS update    Enabled
Public Key store    Sha256
Signature algorithm    PKCS#1v1.5/PSS
BIOS flash method    Runtime,Capsule,Recovery
Flash write-protection    Disabled

Security:
System Mode        Setup (ausgegraut)
Secure Boot        Not Active

[QUOTE] Key Management (ausgegraut)[/QUOTE]

Secure Boot        Disabled
Secure Boot can be enabled if
1. System running in User mode
with enrolled Platform Key(PK)
2.CSM function is disabled

Enabled:
"Platform in Setup Mode!

Secure Boot can be enabled when Platform is in User Mode.
Repeat operation after enrolling Platform Key(PK).

OK"

Compliancy        UEFI 2.3; PI 1.2
Project Version        Windesk 9 plus 3G V1.7.6

Habt ihr noch irgendwelche Ideen? Was macht man in diesem Fall, außer sich vielleicht an den Support von ODYS zu wenden?
Die Flash HDD selbst wechseln ist keine Option, oder? Ich wüsste gar nicht, wie man das Gerät öffnen kann.
Hatte mir mal das Support-Formular angeschaut, dort wird nach einer Seriennummer gefragt, die sich hinten auf dem Gerät oder auf
der Verpackung befinden soll (scheint aber kein Pflichtfeld zu sein). Ich finde keine Seriennummer, und die Verpackung habe ich nicht mehr.
Das Kaufdatum ist ein Pflichtfeld, ich habe aber keinen Kassenbeleg mehr. Soll ich ein ungefähres Datum eintragen?

Bin für jede Idee dankbar. Wenn ich noch irgendwas ausprobieren kann, was ich noch nicht ausprobiert habe, tue ich das gerne.
 
areiland

areiland

Super-Moderator
Dabei seit
25.08.2014
Beiträge
29.640
Ort
Ludwigshafen
Version
Windows 10 Pro x64 immer aktuell!
System
970M Pro3, FX8350, RX560, 16GB DDR3 1600, 860Evo256 GB, MK7559GSXP, SH224BB, BenQ GW2780
Die Flash HDD selbst wechseln ist keine Option, oder?
Kannst Du vergessen, die Dinger sind als Speicherchips direkt auf dem Mainboard verlötet.
Sprich also den Odys Support an, vielleicht kommen die Dir ja aus Kulanz entgegen.
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Ah, verstehe, danke für die Info.
In Ordnung, dann werde ich mein Glück versuchen.
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Habe vom Support die Antwort bekommen, ich sollte das Image von der Odys-Homepage für das Gerät herunterladen und versuchen, auf dem Gerät einzuspielen,
leider ohne Erfolg:
Windesk_9_Plus_3G_V2_Boot_USB_Error.jpg


Eigentlich hätte es wie in folgender Anleitung beschrieben, ablaufen sollen: Installationsanleitung Image Windesk 9 V2

Habe dem Support anschließend den Fehler mitgeteilt, wurde jedoch nur auf den direkten Imagelink verwiesen (welches ich ja bereits
selbstständig gefunden hatte). Nun kommt nach erneuter Antwort keine Rückmeldung mehr.

Kann ich noch irgendetwas tun, wie z.B. den Controller der SSD auf Funktionalität zu überprüfen? Oder könnte hier nur
die Hardwareabteilung der Firma helfen, gibt es keine Tools (mit UEFI-Bootmöglichkeit), die mir den Defekt bestätigen könnten?

Bei der Starthilfe ist das ODYS-Logo zu sehen und der Text "Diagnose des PCs wird durchgeführt", gefolgt von "Reparaturen werden ausgeführt", letztlich wird aber nur neu gestartet, und die Probleme bestehen weiterhin.
 
Zuletzt bearbeitet:
Lasco

Lasco

Erfahrener Benutzer
Dabei seit
26.02.2015
Beiträge
1.700
Version
1909 WIN_10_Pro up_to_date
Hallo,

teste das mal mit der Umstellung im BIOS Richtung >> User Mode

Im Anschluss solltest Du umstellen können auf >> Secure Boot

Nun sollte die Installation funzen...i hope so ;)

Screen:
Opera Momentaufnahme_2021-06-12_153404_www.win-10-forum.de.png


Gruß-Lasco
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Hallo Lasco,

vielen Dank für deine Antwort, hat mir geholfen, das Key Management im BIOS endlich zu aktivieren. Ich muss den "Secure Boot Mode"
auf "Custom" stellen:
BIOS_01.jpg

Nun hätte ich jedoch noch 1-2 Fragen vorab:

Wie würde die Aktivierung des Secure Boots helfen, die Installation auszuführen? Du meinst die Installation des ODYS-Images?
Ich hatte einmal gelesen, dass der Secure Boot deaktiviert werden sollte, bevor man versucht von USB zu booten.
Im BIOS steht, dass der Secure Mode aktiviert werden kann, indem:
  1. System im User-Mode läuft
  2. CMS-Funktion deaktiviert ist
BIOS_00.jpg


Ich habe eben nochmal die Advanced Settings im BIOS durchgesehen, und eine "Legacy USB Support [Enabled]"-Option gefunden,
könnte das die CSM-Funktion sein?

Soll ich:
- unter "Key Management" die "Default Key Provision" auf [Enabled] stellen:
BIOS_03.jpg

- oder die Option "Enroll All Factory Default Keys" durchführen?
BIOS_04.jpg
 

Anhänge

  • BIOS_03.jpg
    BIOS_03.jpg
    151,9 KB · Aufrufe: 5
Lasco

Lasco

Erfahrener Benutzer
Dabei seit
26.02.2015
Beiträge
1.700
Version
1909 WIN_10_Pro up_to_date
Hallo,

um diese Option >> Key-Magement solltest Du einen großen Bogen machen und Dich ausschließlich im >> Secure Boot Mode aufhalten!
Installiere einfach in diesem Modus (#Secure Boot) Dein komplett neues Windows-Image - also ohne dieses Firmware-Image von Odys ;)

Erstelle einen Installations-Stick mit dem MCT-Tool von Microsoft und installiere nach Anleitung Windows 10 auf Deinem Gerät - also unabhängig von der Odys-Installations-Empfehlung!
Beachte dabei die Architektur - 32Bit bzw. 64Bit!

Somit bist Du unabhängig und "zickenfrei" was das Betriebssystem angeht ;)
Viel Erfolg ;)

Gruß - Lasco
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Danke für eure Tipps und den Link.

Bei der Option "Secure Boot" steht, dass dieser Modus nur aktiviert werden kann, wenn System im User-Mode läuft (mit ausgerolltem PK und CSM-Funktion ausgeschaltet ist)

Und bei der Option "Enroll All Factory Default Keys" ist wiederum angegeben, dass diese Option es erzwingt, das System in den User-Mode zu bringen, so dass dies wohl ausgeführt werden müsste unter "Key Management".

Hier steht auch, dass der Secure Boot für die Installation deaktiviert werden sollte (was bei meinem System ja der Fall ist): Image-Erstellung

Aber ich denke, dass die Flash HDD defekt ist. Ich hatte ja bereits eine Windows-Neuinstallation versucht durchzuführen, sogar die korrekte Version (1803), die auch auf dem System installiert war, jedoch ohne Erfolg. Ich komme ja auch ins Setup, aber dort wird bereits weniger Speicher des Datenträgers angezeigt, als dieser tatsächlich vorweist (7.2GB vs. 32 GB). Der Controller ist vermutlich defekt, aber das könnte nur ODYS überprüfen.

Bei der Neuinstallation geht es nicht weiter:
Win10_Installation_01.jpg

Hier erscheint bereits die Meldung, dass nicht genügend Speicher vorhanden sei.

Wenn ich auf "Neu" klicke, erscheint die untere Fehlermeldung, und es geht nicht weiter:
Win10_Installation_02.jpg

Eigentlich sollten, wie hier beschrieben (Image-Installation), die Partitionen angelegt werden, aber es mündet im Fehler 0x80300002.
Ich habe ja auch bereits die Konsole aufgerufen, und mit diskpart alles analysiert, Laufwerk C:\ mit der alten Windows-Installation existiert nicht mehr.
Auch im BIOS müsste ja der Windows Boot Manager als Boot-Option angezeigt werden, was aber nicht der Fall ist.

Hier kann ich also nur hoffen, dass ODYS Interesse daran hat, den Controller mit einem entsprechenden Gerät zu überprüfen.
 
Lasco

Lasco

Erfahrener Benutzer
Dabei seit
26.02.2015
Beiträge
1.700
Version
1909 WIN_10_Pro up_to_date
Hallo,

der oben erwähnte >> CSM-Mode (Legacy-Mode) bedeutet, dass Du u.a. auch fremde Betriebssysteme installieren kannst...

Mein Vorschlag wäre, dass Du Dir mit z.B. Rufus einen Installations-Stick für das Linux OS Ubuntu (als Beispiel) erstellst um zu testen, ob Deine interne Festplatte dann erkannt wird! Linux reagiert da manchmal etwas unempfindlicher als Windows... ;)

Es ist ja offensichtlich so, dass Dein interner Flash-Speicher nicht mehr erkannt wird!
Diese angezeigte Partition von 7,2 GB ist ja lediglich ein virtueller Speicher, welcher von Windows vorgehalten wird und nicht physisch zur Verfügung steht - für eine Installation von Windows OS schon garnicht!

Erstelle also mit z.B. Rufus einen Installations-Stick für das Linux-OS Ubuntu im UEFI-Mode (!) und versuche im Anschluss dieses OS auf Deiner Maschine zu installieren. Im besten Falle wird Dein Flash-Speicher wieder erkannt!

Im Anschluss kannst Du dann versuchen das Windows OS auf diesen Flash-Speicher zu installieren...danach käme dann die Deinstallation des Ubuntu OS...ist die Festplatte mal da, sollte alles wieder wie gewohnt funktionieren...
Vielleicht kann dadurch die eingebaute Festplatte (Flach-Speicher) wieder reaktiviert (erkannt) werden...i hope so ;)

Linik-1: Rufus - Erstellen Sie bootfähige USB-Laufwerke auf einfache Art und Weise

Link-2: Download Ubuntu Desktop | Download | Ubuntu

Einfach mal testen - hast ja nix mehr zu verlieren ;)

Gruß - Lasco
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Danke für die Infos mit dem virtuellen Speicher und auch dem Tipp mit Ubuntu, Lasco, das kann ich mal ausprobieren.
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Ich habe heute mal die Ubuntu-Installation gestartet, und dort wird mir tatsächlich die Windows-Partition mit der Recovery und Boot-Partition angezeigt:
Ubuntu_Inst_02.jpg

Ansicht nach dem Scrollen:
Ubuntu_Inst_03.jpg


Bevor ich Ubuntu installiere, wollte ich mir die Situation mit Testdisk ansehen, und dort werden alle Partitionen als "Deleted" angezeigt:
Testdisk_01.jpg

Ich habe daraufhin versucht, diese auf "Primary" zu setzen und die Partitionstabelle neu zu schreiben, aber es wird leider nicht übernommen. Beim Booten des Gparted Live Images werden u.a. diese Informationen angezeigt:
"the disk contains an unclean file system (0,0)
"the ntfs partition is in an unsafe state"

In Testdisk konnte ich mir sogar auch das Dateisystem der Windows-Partition ansehen.

Nun überlege ich, Ubuntu über die Windows-Partition zu installieren, also "Festplatte löschen und Ubuntu installieren" auszuwählen, oder sollte ich mit den Partitionen hantieren?
Ubuntu_Inst_01.jpg


Aber es war schon mal auf jeden Fall ein super Tipp mit Ubuntu. Sehr überraschend, dass man erst unter Linux wirklich mit der
Analyse einer defekten Windows-Installation beginnen kann.

Der Plan wäre also Ubuntu zu installieren, und anschließend mit dem Windows 10 Boot USB Stick die Partition mit Linux zu löschen,
neue Partitionen wie unter folgendem Link beschrieben durch Klick auf "Neu" anzulegen, und Windows anschließend zu installieren.
 

Anhänge

  • Ubuntu_Inst_01.jpg
    Ubuntu_Inst_01.jpg
    589,3 KB · Aufrufe: 10
Lasco

Lasco

Erfahrener Benutzer
Dabei seit
26.02.2015
Beiträge
1.700
Version
1909 WIN_10_Pro up_to_date
Na das ist doch schonmal eine vielversprechende Rückmeldung ;)

Bedenke - bei LINUX musst Du in dem FAT32-Format bzw. exFAT-Format (Microsoft-Alternative) unterwegs sein für eine erfolgreiche Installation!
Installiere doch erstmal UBUNTU und lass die Maschine "anlaufen"...
Im zweiten Durchgang installiere zusätzlich Windows 10 hinzu...
Im dritten Anlauf machst Du eine komplette Neuinstallation mit Windows 10...zwischenzeitlich sollte der interne Flash-Speicher ja wieder erkannt (eingehängt) sein - sofern die Rückmeldung von LINUX-Ubuntu kommt!

Du bist also auf einem guten Weg, die Maschine wieder unter Kontrolle zu bringen - halt über den Umweg mit LINUX ;)

Viel Erfolg ;)

Gruß - Lasco
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Danke Lasco, werde mein Bestes geben. Dank deinem Tipp hat das Gerät noch eine Chance.
Soweit ich weiß, wird Ubuntu mit dem ext4-Dateisystem installiert, sollte alles passen.
Ich werden dann die Optiion "Festplatte lösche und Ubuntu installieren" wählen, und später Windows neu aufbügeln, also versuchen
von Schritt 1 zu Schritt 3 zu springen, da der Speicherplatz für beide OS vermutlich nicht ausreichen wird, nehme ich an.

Wollte vorab noch die Antwort vom Support abwarten und noch eine Sache mit einer Boot CD (Partitionierungstool) ausprobieren,
aber dann teste ich das mit Ubuntu.

Das einzige Problem wird sein, dass der Windows-Schlüssel anschließend nicht mehr verfügbar sein wird. Da wird auch das Ausführen
des ODYS-Images nicht viel helfen, denke ich. Aber was soll's, muss ich notfalls noch etwas Geld in die Hand nehmen.

Melde mich die Tage und berichte, wie es gelaufen ist.
 
Lasco

Lasco

Erfahrener Benutzer
Dabei seit
26.02.2015
Beiträge
1.700
Version
1909 WIN_10_Pro up_to_date
Nee Stopp!

Installiere UBUNTU und anschließend Windows 10 als zweites Betriebssystem in der 32Bit Version!
Das sollte von der Festplattenkapazität ausreichen - UBUNTU braucht nicht sehr viel Platz und Windows 10 in der 32Bit Version auch nicht sonderlich viel mehr...einfach mal testen ;)
Ansonsten könnte Dir das Erkennungsproblem des Flash-Speichers wieder einen Strich durch die Rechnung machen...
Also den Test erstmal im Dual-Boot mit UBUNTU und Windows 10 durchführen!
War Dies erfolgreich, im Anschluss das Windows OS als alleiniges Betriebssystem installieren...

BTW: Sofern das Gerät mit Windows 8 ausgeliefert wurde ist der Windows-Product-Key im BIOS/UEFI hinterlegt! Da Du offensichtlich mit Windows 10 vor dem Crash unterwegs warst ist die Lizenz wohl auch digital auf dem Microsoft-Server registriert...also diesbezüglich solltest Du Dir erstmal keine großen Sorgen machen ;)

Versuch macht kluch ;)
Viel Erfolg ;)

Gruß - Lasco
 
Wolf.J

Wolf.J

Erfahrener Benutzer
Dabei seit
28.02.2017
Beiträge
5.189
Version
Verschiedene WIN 10
Jedenfalls um den Windows-Schlüssel musst Du Die keine Gedanken machen.
Bei der Neuinstallation von Windows klickst Du dann einfach " ich habe keinen Key" der ist an die Hardware gebunden und wird nach Installation automatisch für die Windows-Aktivierung sorgen.
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Okay, das ist schon mal gut zu wissen mit dem Key, danke.
Alles Klar, Lasco, dann versuche ich es mit Dual Boot vorweg, wenn das der bessere Weg ist.
Während der Windows-Installation (nachdem Ubuntu installiert wurde) sollte mir ja der noch übrige Speicherplatz angezeigt werden,
der dann hoffentlich ausreicht, und ich über "Neu" weitere Partitionen anlegen lassen kann.
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Hab alles versucht, jedoch leider ohne Erfolg.
Während der Einrichtung der ext4-Partition bleibt der Balken stehen, später friert es auch komplett ein.
Habe auch mal versucht, die Partitionen per Hand einzurichten, jedoch ähnlicher Effekt.
Der Versuch sich die Partitionen in GParted anzusehen scheiterte ebenfalls, da die während der Ubuntu-Installation
angezeigten Partitionen dort leider nicht angezeigt werden.

Fazit: Die Flash HDD ist defekt, das haben ja auch schon die Versuche mit Testdisk gezeigt.
Schade, dass ODYS die Kommunikation eingestellt hat. Aber es war einen Versuch wert,
auch wenn es letztlich frustrierend war, trotzdem danke für die Hilfe.
 
K

kvirkeson

Neuer Benutzer
Threadstarter
Dabei seit
06.06.2021
Beiträge
13
Habe gestern nochmal beim Support nachgehakt und stellt euch vor, sie wollen das Gerät,
wie @areiland zu Anfang bereits sagte, aus Kulanz zurücknehmen und neu einrichten.
Es wurde zwar geschrieben, ich solle die Rechnungskopie beilegen, aber hatte ja bereits erwähnt,
dass die Garantie abgelaufen sei, und einen Kassenbon habe ich auch nicht mehr. Hoffe, dass das
trotzdem klappt.

Jetzt habe ich ja gestern mit Ubuntu experimentiert und neue Partitionen angelegt (ext4 & ESP),
hoffe das wird kein Problem sein.

...und wie wollen die das wieder neu installieren? Ist es möglich, diese Geräte für den Hersteller zu
öffnen, oder mit speziellen Geräten den Speicher zu resetten/neu aufzusetzen?
 
Zuletzt bearbeitet:
Thema:

ODYS Windesk 9 plus 3G V1.7.6 Flash HDD nicht mehr erkannt

ODYS Windesk 9 plus 3G V1.7.6 Flash HDD nicht mehr erkannt - Ähnliche Themen

Wie BCD ID (BCDEDIT Bezeichner) ändern?: Hallo, nach dem klonen einer eingebauten nicht trennbaren eMMC auf eine externe USB HDD/SSD ist die BCD ID (BCDEDIT Bezeichner) gleich. Booten...
M.2 Samsung Evo 970 in Bios erkannt, aber nicht bei Windows: Hallo zusammen, ich habe mir einen neuen Rechner mit neuen Komponenten zusammengebaut und mein System erkennt meine Samsung Evo 970 nicht. Im...
Altsystem gelöscht - neues System startet nicht mehr: Hallo zusammen, ich habe seit längerer Zeit 2 Systeme im dual boot in meinem PC. Beide Windows 10. Altes System: HDD 1TB und Windows auf SSD...
MS FlightSimulator 2020 startet nicht: Hallo zusammen, habe den FS2020 bei Amazon als Downloadversion gekauft. Das freischalten im Store und die Installation verlaufen schnell und...
Bluescreens nur bei Spielen: Hallo alle zusammen! Mein Bruder hat das Problem, das er bei bestimmten Spielen, zum Beispiel bei Path of Exile immer schon nach 2-3 manchmal...
Oben