Nummernblock beim Bootvorgang aktivieren - so wird´s gemacht

Diskutiere Nummernblock beim Bootvorgang aktivieren - so wird´s gemacht im Windows 10 FAQ Forum im Bereich Windows 10 Foren; Wer seinen Computer einschaltet und die neue Pin-Eingabe von Windows 10 nutzen möchte, stößt vielleicht auf das Problem, dass der Nummernblock auf...
maniacu22

maniacu22

Erfahrener Benutzer
Threadstarter
Mitglied seit
05.05.2014
Beiträge
2.314
Ort
Leipzig
Version
Windows 10 Pro 64 Bit - Build 1709
System
Intel Core i5-3570K, 32 GB RAM, 500 GB Crucial MX200, HIS Radeon HD 5750 Passiv
Wer seinen Computer einschaltet und die neue Pin-Eingabe von Windows 10 nutzen möchte, stößt vielleicht auf das Problem, dass der Nummernblock auf der Tastatur erst noch eingeschaltet werden muss. Wenn euch das genauso nervt, könnt ihr diesen aber auch so einstellen, dass dieser dauerhaft aktiviert bleibt. Wie das geht, erfahrt ihr in diesem Praxis-Tipp



Windows 10 wird Microsofts erstes Betriebssystem sein, bei dem sich via "Windows Hello" über mehrere Wege anmelden lässt. So ist die gewohnte Anmeldung mit Nutzername und Kennwort, Fingerprint, 3D-Gesichtserkennung aber auch eine PIN-Eingabe möglich. Während bei Fingerprint ein spezieller Fingerabdruckscanner und bei der 3D-Gesichteerkennung eine entsprechende Kamera mit der "Real Sense 3D-Technik" benötigt wird, ist die PIN-Vergabe relativ einfach.

Allerdings sind die meisten PCs so eingestellt, dass der Num-Block noch im Login-Bildschirm deaktiviert ist und dieser erst noch mittels Druck auf "Num Lock" aktiviert werden muss. Um dies ändern zu können, bedarf es einer Änderung in der Registry.


  • betätigt hierzu die Tastenkombination "Win + R" und gebt hier "regedit" ein und drückt "Enter"
  • bestätigt die daraufhin folgende Sicherheitsabfrage mit "JA"
  • hangelt euch jetzt über "HKEY_CURRENT_USER" - "Control Panel" - "Keyboard"
  • wählt jetzt "InitialKeyboardindicators" mit einem Doppel-Linksklick an
  • setzt nun den "Wert" auf "2" und bestätigt mit "OK"




Wenn ihr jetzt euren Rechner neu startet, wird die Einstellung übernommen und ist gleich Anwendbar. Zukünftig benötigt ihr für die Anmeldung via PIN - Voraussetzung dafür sind natürlich Zahlen - einen Tastendruck weniger, da der Num-Block schon beim Booten zur Verfügung steht.

Meinung des Autors: Die Anmeldung im Windows 10 via PIN-Eingabe vereinfacht schon einiges. Ob es sicherer als andere Anmeldevorgänge ist, sei mal dahin gestellt. Wichtig ist, dass der Num-Block gleich nach dem Einschalten des PCs zur Verfügung steht und man die PIN ohne vorheriges Drücken auf "Num Lock" eingeben kann. Eine wirkliche Zeitersparnis stellt es zar nicht dar, aber es schont die Nerven. Welche Anmelde-Variante nutzt ihr an eurem Windows-10-PC? klassisch via Nutzername und Passwort, PIN-Abfrage oder Fingerabdruck? Oder nutzt schon jemand die 3D-Gesichtserkennung?
 
#
Schau dir mal diesen Ratgeber an. Dort wird jeder fündig!
Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
E

eskisam

Neuer Benutzer
Mitglied seit
30.07.2015
Beiträge
2
Ort
Falkensee
Version
64bit Pro
System
I7, 12GB, ATI
Das reicht leider nicht (immer) aus. Auch im Registrierungsschlüssel: "HKEY_USERS\.Default\Control Panel\Keyboard" und ggf. alle weiteren "InitialKeyboardIndicators" Einträge müssen auf "2" gesetzt werden.
Herzliche Grüße
rwb
 
R

Rupo10

Neuer Benutzer
Mitglied seit
23.05.2015
Beiträge
13
Ort
Wien AT
Version
Win 10 Pro
Hallo!
Dieser sogenannte "Trick" funktioniert scheinbar nur bei kabelgebundenem Keyboard.
Bei Funk hat das noch nie funktioniert und geht - leider - auch jetzt nicht.
 
G

Gast

Es ist kein Registryeingriff nötig wenn man Numlock im Bios schon auf aktiviert setzt.
 
DaTaRebell

DaTaRebell

Erfahrener Benutzer
Mitglied seit
13.09.2014
Beiträge
1.566
Ort
Gronau / Westfalen
Version
Windows 10 Enterprise WinToGo
System
Samsung RF711, Intel i5, Intel HD 3000 & nVidea 540M
Ob die Tastatu/Maus über Kabel oder Funk eingebunden ist... es macht keinen Unterschied.
Evtl. mal bei solchen Problemen einen neuen Treiber suchen.
 
H

Heinz

Ich tippe die "NUM LOCK"Taste und der Block ist aktiv. Zu sehen an einer kleinen Led Leuchte darauf. Ich tippe nochmal darauf,dann ist der Block wieder deaktiviert und die Lampe erlöscht. Offenbar werde ich hier mit Glück erschlagen,dass es so einfach geht.
PS. Mein BIOS ist generell auf "Default"gestellt.
 
Zuletzt bearbeitet:
wildcatandwolf

wildcatandwolf

Benutzer
Mitglied seit
25.01.2015
Beiträge
42
ich habe schon vor einigen Tagen diese Einstellungen in der Reg vorgenommen, da mit das Problem aus Win8/ 8.1 bekannt war. Nur sind diese Einstellungen nicht von Dauer bzw. sie funktionieren nur zeitweise. >>> Nehme ich die Änderungen jetzt vor und starte den PC neu ist alles OK. Fahre ich den PC runter und starte dann >>> funktioniert die Num-Taste nicht; muss sie erst manuell einschalten. Eine Überprüfung der Reg zeigt die Werte, die eingestellt sein sollten. Num im Bios ist ebenfalls aktiv.
Hier nochmals die Einstellungen, die ich vorgenommen bzw. überprüft habe:
[HKEY_L0CAL_MACHINE\SYSTEM\CurrentControISet\ControI\Session Manager \Environment]
NUMLOCK=”ON”
noch mal in Registry schauen
HKEY_CURRENT_USER\Control PaneI\Keyboard und
HKEY_USERS\.DEFAULT\Control Panel\Keyboard
jeweils bei dem Eintrag „InitialKeyboardIndicators" muss der Wert auf 2 stehen


Wo hier bei meinem Rechner der Fehler liegt ??? KA, muss mich wohl mit dem manuellen Aktivieren abfinden, oder es findet sich eine Lösung; denn es hatte ja einige Tage geklappt, also warum jetzt nicht mehr??
 
Zuletzt bearbeitet:
R

Rupo10

Neuer Benutzer
Mitglied seit
23.05.2015
Beiträge
13
Ort
Wien AT
Version
Win 10 Pro
DaTaRebell
Heinz
Das "Problem" ist sicher nicht lebenswichtig aber nervt etwas
Bios Numlock ein
Logitech Keyboard mit aktuellem Treiber
mfg.
 
areiland

areiland

Super-Moderator
Mitglied seit
25.08.2014
Beiträge
25.062
Ort
Ludwigshafen
Version
Windows 10 Pro x64 immer aktuell!
System
970M Pro3, FX8350, RX560, 16GB DDR3 1600, 860Evo256 GB, MK7559GSXP, SH224BB, BenQ GW2780
Dann führ die Änderungen in der Registry durch. In HKEY_USERS\.DEFAULT\Control Panel\Keyboard wird der Numlock vom Start bis zum Anmeldebildschirm eingeschaltet, in HKEY_CURRENT_USER\Control PaneI\Keyboard für das geladene Benutzerprofil.
 
G

Gast

Das reicht leider nicht (immer) aus. Auch im Registrierungsschlüssel: "HKEY_USERS\.Default\Control Panel\Keyboard" und ggf. alle weiteren "InitialKeyboardIndicators" Einträge müssen auf "2" gesetzt werden.
Herzliche Grüße
rwb
Wenn es trotzdem mit den hier stehenden Tipps nicht klappt, dann solltet Ihr RegEdit als Administrator starten. Das ist bei der systemweiten Einstellung ".DEFAULT" sowieso Pflicht.
 
wildcatandwolf

wildcatandwolf

Benutzer
Mitglied seit
25.01.2015
Beiträge
42
Wenn es trotzdem mit den hier stehenden Tipps nicht klappt, dann solltet Ihr RegEdit als Administrator starten. Das ist bei der systemweiten Einstellung ".DEFAULT" sowieso Pflicht.
auch wenn ich regedit als Admin starte habe ich das selbe Problem, wenn ich den PC runterfahre und später neu starte.
Sofortiger Neustart nach Änderung in der Registry >> Num bleibt eingeschalten
PC ausschalten und wieder starten >>> Num nicht aktiv, muss manuell gestartet werden

Welcher Fehler könnte noch dafür verantworetlich sein??
 
areiland

areiland

Super-Moderator
Mitglied seit
25.08.2014
Beiträge
25.062
Ort
Ludwigshafen
Version
Windows 10 Pro x64 immer aktuell!
System
970M Pro3, FX8350, RX560, 16GB DDR3 1600, 860Evo256 GB, MK7559GSXP, SH224BB, BenQ GW2780
Schalte "Numlock aktiv" mal im UEFI ab - wie verhält es sich dann? Könnte sein, dass die Einstellung von Windows einfach umgedreht wird - also Numlock deaktiviert - wenn er schon aktiv war.
 
wildcatandwolf

wildcatandwolf

Benutzer
Mitglied seit
25.01.2015
Beiträge
42
Schalte "Numlock aktiv" mal im UEFI ab - wie verhält es sich dann? Könnte sein, dass die Einstellung von Windows einfach umgedreht wird - also Numlock deaktiviert - wenn er schon aktiv war.
PC neu gestartet >>> NUM im Bios abgeschalten >>>> PIN Eingabe funktioniert
PC runterfahren >>> einige Sekungen gewartet >>> NUM im BIOS immer noch abgeschalten >>>> PIN Eingabe erst nach Betätigen Num-Lock Taste möglich

in Registry NUM auf OFF gestellt >>> PC neustarten >>> NUM im BIOS aktiv >>> PIN Eingabe funktioniert ohne vorher NUM-Lock-Taste zu betätigen

Jetzt wieder PC runtergefahren >>> in Registry NUM auf OFF gestellt >>> NUM im BIOS aktiv >>> PIN Eingabe erst nach Betätigen NUM-Lock-Taste möglich

Also besteht immer noch irgendwo ein Fehler, den ich nicht entdecke!

Werde jetzt nochmals beide NUM Einstellungen in der Registry und im BIOS deaktivieren, mal sehen was dann passiert!

Habe jetzt:
[HKEY_L0CAL_MACHINE\SYSTEM\CurrentControISet\ControI\Session Manager \Environment]
NUMLOCK=”OFF” gesetzt und im BIOS deaktiviert
Führe ich nach der Registry-Bearbeitung einen Neustart aus und nehme beim Start die Änderung im BIOS vor, kann ich die PIN über den Ziffernblock ganz normal eingeben.
Fahre ich den PC jedoch runter und starte den PC dann, muss ich den Ziffernblock erst über die NUM-Lock-Taste aktivieren.

Im nachfolgenden Verssuch habe ich die Werte in HKEY_CURRENT_USER\Control PaneI\Keyboard und
HKEY_USERS\.DEFAULT\Control Panel\Keyboard
jeweils bei dem Eintrag „InitialKeyboardIndicators" auf 1 gesetzt.

Fahre ich dann den PC runter und starte neu, muss ich den Ziiffernblock erst wieder einschalten.
Der Wert inHKEY_CURRENT_USER\Control PaneI\Keyboard hat sich in "2" geändert. Ein normaler Neustart >>> Ziffernblock kann sofort genutzt werden.
Fahre ich den PC runter und starte dann neu >>> Ziffernbloch muss über NUM-Lock-Taste aktiviert werden.

Egal was ich versuche, nach dem Herunterdfahren des PC und späteren Starten, muss ich den Ziffernblock erst aktivieren!
Finde bisher hierfür keine Lösung.
 
Zuletzt bearbeitet:
G

Gast

Hallo Windows 10 User,

warum so kompliziert, wenn es auch einfacher geht ;)
Einfach die Bildschirmtastatur starten und dort in den Optionen den Ziffernblock aktivieren. Windows merkt sich die Einstellungen auch nach einem Neustart, so dass der "Numblock" schon bei der Anmeldung zur Verfügung steht.

Mfg
Jens
 
G

Gast

Die Lösung mit der Bildschirmtastatur funktioniert auch nicht, sorry.
Muss wohl durch MS gepatcht werden...
 
Copy-Item

Copy-Item

Erfahrener Benutzer
Mitglied seit
26.09.2014
Beiträge
113
Version
Windows 10 Pro x64
Mal nach "Bildschirmtastatur" suchen, oder osk.exe ausführen.
 
wildcatandwolf

wildcatandwolf

Benutzer
Mitglied seit
25.01.2015
Beiträge
42
Mal nach "Bildschirmtastatur" suchen, oder osk.exe ausführen.
Bezogen auch auf meine Mitteilungen vom 07.08.2015 sind alle Aktionen wirkungslos.
Es bleibt wirklich nur das manuellen Aktivieren per NUM-Lock-Taste oder die Eingabe über die normalen Zifferntasten.

ENdlich ein positives Ergebnis:

Das Problem hat sich seit gestern ganz von alleine gelöst. Scheinbar wurde dieser Fehler mit den letzten Win10-Updates mit behoben. Jedenfalls bleibt der Ziffernblock jetzt aktiviert und muss nicht manuell aktiviert werden.
Inwieweit sich Änderungen in der Registry oder BIOS ergeben habenmuss ich noch prüfen und werde dann entsprechend berichten.

Läuft jetzt seit 7 Tagen ohne erneutes Problem! Wie oder durch was oder durch welches Updat evtl. behoben ?? >> ich weiss es nicht!
 
Zuletzt bearbeitet:
G

Gast

Hm, leider immer noch kein "Fix" da.
Wir warten auf das nächste Update...
 
B

BlackEagle

Neuer Benutzer
Mitglied seit
27.07.2015
Beiträge
7
Version
Windows 10 Pro Build 10130
PC neu gestartet >>> NUM im Bios abgeschalten >>>> PIN Eingabe funktioniert
PC runterfahren >>> einige Sekungen gewartet >>> NUM im BIOS immer noch abgeschalten >>>> PIN Eingabe erst nach Betätigen Num-Lock Taste möglich

in Registry NUM auf OFF gestellt >>> PC neustarten >>> NUM im BIOS aktiv >>> PIN Eingabe funktioniert ohne vorher NUM-Lock-Taste zu betätigen

Jetzt wieder PC runtergefahren >>> in Registry NUM auf OFF gestellt >>> NUM im BIOS aktiv >>> PIN Eingabe erst nach Betätigen NUM-Lock-Taste möglich

Also besteht immer noch irgendwo ein Fehler, den ich nicht entdecke!

Werde jetzt nochmals beide NUM Einstellungen in der Registry und im BIOS deaktivieren, mal sehen was dann passiert!

Habe jetzt:
[HKEY_L0CAL_MACHINE\SYSTEM\CurrentControISet\ControI\Session Manager \Environment]
NUMLOCK=”OFF” gesetzt und im BIOS deaktiviert
Führe ich nach der Registry-Bearbeitung einen Neustart aus und nehme beim Start die Änderung im BIOS vor, kann ich die PIN über den Ziffernblock ganz normal eingeben.
Fahre ich den PC jedoch runter und starte den PC dann, muss ich den Ziffernblock erst über die NUM-Lock-Taste aktivieren.

Im nachfolgenden Verssuch habe ich die Werte in HKEY_CURRENT_USER\Control PaneI\Keyboard und
HKEY_USERS\.DEFAULT\Control Panel\Keyboard
jeweils bei dem Eintrag „InitialKeyboardIndicators" auf 1 gesetzt.

Fahre ich dann den PC runter und starte neu, muss ich den Ziiffernblock erst wieder einschalten.
Der Wert inHKEY_CURRENT_USER\Control PaneI\Keyboard hat sich in "2" geändert. Ein normaler Neustart >>> Ziffernblock kann sofort genutzt werden.
Fahre ich den PC runter und starte dann neu >>> Ziffernbloch muss über NUM-Lock-Taste aktiviert werden.

Egal was ich versuche, nach dem Herunterdfahren des PC und späteren Starten, muss ich den Ziffernblock erst aktivieren!
Finde bisher hierfür keine Lösung.

Genauso ist es bei mir auch.

Es gibt zig Seiten die behaupten das es gelöst ist!
IST E ABER LEIDER NICHT !
Bei einem NEUSTART ist die NUM bei mir auch immer an.

Aber fahrt den PC mal herutner und startet ihn dann wieder!!! ;)

Keiner redet von neustarten. Reset, das funktioniert wenn sie einmal mit dem Tastendruck aktiviert wurde. Nur wenn der PC ausgeschaltet ist, und wieder eingeschaltet wird ist sie immer standartmässig aus.

und leider hilft weder bei beiden reg einsträgen eine 1 zum deaktivieren, eine 2 zum Aktivieren noch die lange zahlenreihenfolge.

es geht nicht, im Bios habe ich keine Funktion dafür.

Logitech Setpoint Aktuell
Tastatur, Kabel, Logitech G510

sorry, bin sehr genervt um die zig Falschmedlungen, nur weil manche neustart und Pc ausschalten und einschalten nicht unterscheiden können ^^
 
Thema:

Nummernblock beim Bootvorgang aktivieren - so wird´s gemacht

Sucheingaben

num lock einschalten windows 10 ohne regedit

,

windows 10 num lock beim bootvorgang aktivieren/deaktivieren

,

bios numlock aktivieren

Nummernblock beim Bootvorgang aktivieren - so wird´s gemacht - Ähnliche Themen

  • Nummernblock Tastatur

    Nummernblock Tastatur: Wieso kann ich mich mit Nummernblock anmelden und wenn Windows vollständig hochgefahren und geladen ist steht mir der Nummernblock an meiner...
  • Nummernblock funktioniert nicht!

    Nummernblock funktioniert nicht!: Hallo, mein Nummernblock funktioniert nicht mehr, wer weis Rat?
  • Nummernblock

    Nummernblock: Habe bereits vor einigen Tagen gefragt, ob mir jemand sagen kann, was zu tun ist, wenn die Ziffer "0" nicht mehr vorhanden zu sein scheint (alle...
  • Acer Laptop deaktiviert Nummernblock beim Start

    Acer Laptop deaktiviert Nummernblock beim Start: Hallo zusammen, ich habe mir vor Kurzem einen neuen Laptop von Acer gekauft, der auch einen Nummernblock hat. Dieser deaktiviert sich aber bei...
  • Nummernblock beim Starten von Windows 10 zeitweise deaktiviert

    Nummernblock beim Starten von Windows 10 zeitweise deaktiviert: Hallo, ich habe folgendes Problem. da ich ein Passwort mit Zahlen und Buchstaben habe ist es ziemlich nervig. Wenn ich den PC starte bootet er...
  • Ähnliche Themen

    • Nummernblock Tastatur

      Nummernblock Tastatur: Wieso kann ich mich mit Nummernblock anmelden und wenn Windows vollständig hochgefahren und geladen ist steht mir der Nummernblock an meiner...
    • Nummernblock funktioniert nicht!

      Nummernblock funktioniert nicht!: Hallo, mein Nummernblock funktioniert nicht mehr, wer weis Rat?
    • Nummernblock

      Nummernblock: Habe bereits vor einigen Tagen gefragt, ob mir jemand sagen kann, was zu tun ist, wenn die Ziffer "0" nicht mehr vorhanden zu sein scheint (alle...
    • Acer Laptop deaktiviert Nummernblock beim Start

      Acer Laptop deaktiviert Nummernblock beim Start: Hallo zusammen, ich habe mir vor Kurzem einen neuen Laptop von Acer gekauft, der auch einen Nummernblock hat. Dieser deaktiviert sich aber bei...
    • Nummernblock beim Starten von Windows 10 zeitweise deaktiviert

      Nummernblock beim Starten von Windows 10 zeitweise deaktiviert: Hallo, ich habe folgendes Problem. da ich ein Passwort mit Zahlen und Buchstaben habe ist es ziemlich nervig. Wenn ich den PC starte bootet er...
    Oben