Excel VBA: Wie gebe ich in einer FormularLocal-Formel einen Zeilenumbruch mit ein?

Diskutiere Excel VBA: Wie gebe ich in einer FormularLocal-Formel einen Zeilenumbruch mit ein? im Office Forum im Bereich Microsoft Community Fragen; Hallo Leute, folgende Frage: Ich habe eine intelligente Tabelle mit Kopfleiste. Diese intelligente Tabelle beinhaltet mehrere Spalten und eben...

MSCom

Neuer Benutzer
Threadstarter
Dabei seit
20.09.2016
Beiträge
1
Hallo Leute,

folgende Frage:
Ich habe eine intelligente Tabelle mit Kopfleiste. Diese intelligente Tabelle beinhaltet mehrere Spalten und eben die Kopfleiste. Nun soll mit einem Makro über VBA per .FormularLocal eine Zelle in der intelligenten Tabelle mit einer Formel befüllt werden.


Die Formel im händischen Entwicklungsprozess sieht wie folgt aus und funktioniert bei händischer Eingabe auch:

=WENN(UND([@[Status
Test]]="fertig";[@[Status]]="erledigt");SVERWEIS([@[AP]];Grunddaten!$A$25:$G$35;3;FALSCH);"")

Das Problem, an dem ich gerade scheitere, ist, dass in der UND-Verknüpfung in der Spalte "Status Test" zwischen "Status" und "Test" ein echter eingegebener Zeilenumbruch enthalten ist (ALT+Eingabe).

"Status Test" sieht folglich eigentlich so aus:

"Status

Test"

Nun kenne ich die Tricks, entweder den String vorher zusammenzubauen und dann in .FormulaLocal einzusetzen oder dies direkt zu tun. In beiden Fällen würden die Anführungszeichen gedoppelt, also so:

.FormularLocal="=WENN(UND([@[Status
Test]]=""fertig"";[@[Status]]=""erledigt"");SVERWEIS([@[AP]];Grunddaten!$A$25:$G$35;3;FALSCH);"""")

Nur, was mache ich mit dem Zeilenumbruch? Lasse ich den weg, landet die Zelle einzeilig im Ziel und funktioniert folglich nicht...

Hat einer eine Idee? Habt vielen Dank für jeden Support!

LG,
Matse
 
Thema:

Excel VBA: Wie gebe ich in einer FormularLocal-Formel einen Zeilenumbruch mit ein?

Excel VBA: Wie gebe ich in einer FormularLocal-Formel einen Zeilenumbruch mit ein? - Ähnliche Themen

Excel VBA Problem mit Find: Hallo, NG, ich habe totale Probleme mit Find - Excel liefert einfach nicht die richtigen Ergebnisse, hier mein gekürzter Code: Function...
Excel VBA alle nicht verwendeten Spalten und Zeilen ausblenden und nur verwendete einblenden.: Hallo, ich beschäftige mich derzeit mit dem Buch "VBA mit Excel" Hier wird unteranderem erklärt wie man Spalten und Zeilen per Macro ein und...

Sucheingaben

desert diamond casino

,

apoker supplies

,

tangiers casino

,
tangiers cas3ino
, majestic star casino, majestic star cagsino, play poker for free, play pokeIr for free, niagara falls casino, niagara falls casinCo, how do u play poker, poker lessons, skagit valley ca]sino, skagit valley casino, desert diamond cQasino, poker chip tricks, casino club, casiVno club, three card poker rules, three card poQker rules, philadelphia casinos, philadelphia cahsinos, windsor casingo, paradise poker, paradise Ppoker
Oben