Hallo,
um mein Problem zu schildern, werde ich diesen Post in verschiedene Abschnitte aufteilen:

1.Ausgangssituation
Im April habe ich meinen Prozessor, Mainboard und Arbeitsspeicher gewechselt. Mein damaliges System bestand aus:
Intel Core i5-4570
Gigabyte Z87-HD3
8GB DDR3 RAM (mir jetzt gerade unbekanntes Modell)
Asus Radeon R9 390X Direct CUII
Be Quiet Dark Power Pro 10 750 Watt
1TB Seagate Festplatte

Der Prozessor, Mainboard und Arbeitsspeicher wurden gegen folgende Komponenten getauscht:
Intel Core i7-6700
MSI Z170-A Pro
16GB DDR4-2133 von G.Skill
Dazu gesellte sich eine Samsung SSD 850 Evo 120GB
Der Rest des Systems blieb gleich.

Die jetzige Konfiguration folgt weiter unten.

2.Das Problem
Seit diesem Hardwarewechsel friert der PC in unregelmäßigen Abständen ein. Dies äußert sich darin, dass ich auf dem Desktop die Maus nicht mehr bewegen kann und auch z.B. die Uhrzeit stehen bleibt, d.h. ich kann den Zeitpunkt des Einfrierens genau nachvollziehen. Der PC läuft aber weiter, die Lüfter lüften fröhlich vor sich hin, und selbst der Monitor schaltet sich gemäß Windows-Einstellungen (in meinem Fall nach 15 Minuten) ab. Aufwecken kann ich ihn in diesem Fall aber nicht mehr, da die Maus nicht mehr funktionstüchtig ist.
Die LED für die Festplattenaktivität blinkt auch nicht mehr. Fast immer tritt dies auf dem Desktop auf, bzw. wenn der PC kaum Last ausgesetzt ist, also beim Surfen, Download oder im Leerlauf. Beim Spielen, wofür der PC hauptsächlich genutzt wird, friert der PC sehr selten ein.

Das Einfrieren tritt letztendlich in drei (vier) verschiedenen Formen auf:
1.Einfaches Einfrieren, bei dem sich nichts mehr machen lässt, Festplatten-LED am Gehäuse blinkt nicht mehr. Uhrzeit bleibt stehen.
2.Einfrieren mit Abschalten aller USB-Geräte. D.h. dass z.B. die LED der Maus nicht mehr leuchtet, Headset-LED leuchtet nicht mehr, Gamepads werden abgeschaltet. Sonst die gleichen Symptome wie bei "1." .
3.Einfrieren beim Spielen. Dies tritt sehr selten auf. Begleitet wird es immer von einem lauten, stetigen, undefinierbaren Sound im Headset. Dieser tritt manchmal auch bei Punkt 1 und 2 auf. Gelegentlich schalten sich die USB-Geräte wie bei "2." beschrieben ab.
(4.)Manchmal kommt es vor, dass das System mit Starten des MSI Afterburner einfriert, immer begleitet vom oben genannten Sound im Headset. Allerdings friert das System auch ein, wenn der Afterburner deinstalliert wurde, bzw. auch auf einem frisch installiertem System ohne Afterburner.

3.Was ich bisher gemacht habe
Kurz: nicht sehr viel. Denn das Problem tritt so oft auf, dass es nervt, aber nicht oft genug, dass es mich zu einer ausgiebigen Problemsuche animiert hat. Was ich aber gemacht habe, ist, dass ich mehrmals mehrstündige Memtests durchgeführt habe, ohne Ergebnis. Windows habe ich mehrmals neu installiert. Aber es tritt sowohl unter Windows 8(.1) als auch unter Windows 10 auf. BIOS habe ich auch schon zurückgesetzt. Sowohl Treiber als auch das BIOS sind aktuell.
Zuletzt habe ich eine neue SSD (um dies als Fehlerquelle auszuschließen) gekauft, die Alte ausgebaut und die Festplatte abgestöpselt und eine Neu-Installation durchgeführt. Der PC friert weiterhin ein.

4.Abschließend
Um die Frage vorwegzunehmen, ob ich irgendwas übertaktet habe: Nein. Ich habe lediglich für einen kurzen Zeitraum die Grafikkarte per MSI Afterburner undervoltet und etwas heruntergetaktet. Das Problem bestand aber vor, während und nach der dieser Maßnahme.

Nun noch einmal meine jetzige Konfiguration:
Intel Core i7-6700
MSI Z170-A Pro
16 GB DDR4-2133 von G.Skill
Asus Radeon R9 390X DirectCUII
SanDisk SSD Plus 480GB
Be Quiet Dark Power Pro 10 750Watt

Ich hoffe, dass es eine Lösung gibt.
Und schon einmal Danke an alle, die sich bemühen, eine Lösung zu finden.